yarn outdated

Проверка пакетов на устаревшие зависимости.

yarn outdated

Выводит информацию о версиях всех зависимостей пакета. Эта информация включает установленную версию, рекомендуемую версию, основываяюсь на семантическом версионировании, а также последнюю доступную версию.

На пример, в файле package.json указаны следующие зависимости:

{
  "dependencies": {
    "underscore": "~1.6.0"
  },
  "devDependencies": {
    "lodash": "4.15.0"
  }
}

При выполнении данной команды вы должны получить приблизительно такой вывод:

yarn outdated
Package    Current Wanted Latest Package Type    URL
lodash     4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
underscore 1.6.0   1.6.0  1.8.3  dependencies    https://github.com/jashkenas/underscore#readme
✨  Done in 0.72s.
yarn outdated [имя пакета(-ов)...]

Выводит информацию для одной или нескольких зависимостях пакета.

Например, при использовании файле package.json, из предыдущего примера, вы должны получить следующий вывод при проверки одной из зависимостей:

yarn outdated lodash
Package Current Wanted Latest Package Type    URL
lodash  4.15.0  4.15.0 4.16.4 devDependencies https://github.com/lodash/lodash#readme
✨  Done in 1.04s.